Start a new topic

Quick Keys, Linux, App recognition

I have just received my Quick Keys and it’s really great but it has an issue where it is not seeing any other applications when I try to add new Application Profiles. I only have access to the initial ‘OTHER’ profile and its associated 5 sets. It seemed to install successfully without issue. I am using the standard ‘OTHER’ profile without issue (although sometimes when I update a button I need to exit the driver app and restart it before that button update becomes active on the device.


The problem I have is that when I try to add a new Application Profile it won’t see any of the apps that are running on the system and even if I manually enter the app via navigating to its .bin and set it up that way, the Quick Keys still only actually performs the shortcuts that are set in the ‘other’ profile despite showing the updated named buttons from the new profile on the display. It seems like its stuck in the ‘OTHER’ profile and there is no way to add and use Application Profiles for individual apps so I only have a total of 40 keys I can assign over the 5 sets for all my appllications. On MacOS I get 40 keys per Application Profile and it appears to automatically switch to those profiles when I run the application. My guess is that despite being able to set the profiles up manually, its not letting me use them on Linux if the driver isn’t able to ‘see’ the app is running? I am not running Mac OS and Linux on the same machine, they are two different machines and I have two separate Quick Keys devices, one connected to the Mac and one connected to the PC running Linux.


Any advice would be appreciated.


I am running driver version xencelabs-1.2.1-11.x86_64 on CentOS 7


Thank you.


Thanks for posting this. It sounds like the application icon is not being added to the Application row. It sounds like you are following the correct steps.


I'm going to add the link below to the FAQ that will walk you through the recommended way to add an application to the application row so you can then set up custom settings for them.


** I would like to point out that once you add the application, it is important to click on it so that the "Yellow Bar" is under the application icon when you create your custom settings.


FAQ: https://solutions.xencelabs.com/en/support/solutions/articles/67000544218-how-can-i-make-custom-settings-to-a-specific-application-


Let me know if this helps -

 


[1] Like this - now any custom settings I make will be applied only to Ps. 

Thank you for the reply. Yes that is the way it works perfectly in MacOS but not in Linux. Whenever I try to add an application the driver app doesn’t recognise it and just puts a gear icon where on Mac I am seeing the actual application icon. In MacOS it easily recognises either running applications or applications I navigate to manually, as per the support article, but whatever I do I can’t get it to do the same in Linux - or even to work on another created Application Profile. Once set up any new Application Profile only shows the ‘gear’ icon and won’t perform functions set in the buttons but instead performs the actions only that are set in the ‘OTHER’ profile (even if I change them from the default setting), despite having selected the newly created profile with the yellow underline and the Quick Keys displaying the correct name on the screen.

The Driver team has released a new version of the Linux driver. Please use the link below to go to the Xencelabs driver download page and download the latest version of the driver – 1.2.1-11.


https://www.xencelabs.com/us/support/download-drivers


Please give that a test and let me know how it works for you.


The macOS and Windows drivers do have more functionality in them compared to the Linux driver. The Driver team is working on that.

 

Thank you for the reply.


That seems to be exactly the same version you pointed me to as the one I am already using (1.2.1-11)? Has the new update not been uploaded to your website yet or did you assume I wasn’t using the latest version already?




Thanks.

I have a bit more to add to the story...


With the current version of the Linux driver, you can add applications to the Application row. Still, when you select the icon to make custom edits to the application, it will be added to the "All Other" yellow Globe.


The Linux Driver team is working to fix this. I do not have a time estimate on when it will be corrected.

Thank you for the update. I look forward to getting a working version of the driver!

Login to post a comment