建立新主題

Quick Keys is Unresponsive

Help!


Quick Keys is unresponsive, doesn't charge, display is blank.


I tried:

Power Slide

Holding Power Slide for 10s+

Pushing buttons

Various USB-C Cables

Various Power Sources

Reinstalling Software and Dongle (Doesn't find the Quick Keys)


The only thing I noticed is when I plug it in the Connection and Power indicator lights blink very faintly every 1 second. 


It was working fine for 10 months until now.  Any ideas? I miss it already :(


5 個人 想問一樣的問題

Thanks for posting that. I see that you have created a ticket, and Carson is working with you. 

I've just began having this same issue today.

I sent a ticket in as well.

Hope they're able to find a solution for this. Seems like it's becoming a common problem now

I see you have also created a ticket #16089 with Customer Care. They will reach out to you shortly if they have not already done so and work with you to get you up and running.



I'm having the same problems. Any fix?

Please reach out to Customer Care, and they will be happy to work with you and replace the Quick Keys if needed.


Email Customer Care at CustomerCare@xencelabs.com

Is there a fix for this? Or just send it back?

Sorry to hear that. Please reach out to the Xencelabs Customer Care team by sending an email to OnlineSupport@xencelabs.com.


When you reach out to them, please include your Xencelabs order number or a copy of your receipt and your complete shipping address and phone number. And a few images of the front and back of the Quick Keys, along with the Quick Keys serial number. , This will help expedite getting you up and running.

 

登入 留下意見