Yes, it will work with your macOS operating systems that are 10.12  and newer.